Qualcomm Atheros QCA9377 Adapter [Bug]

Hello, 0x00’ers!

Are there anyone using Qualcomm Atheros QCA9377 Wireless Adapter as their Internal Wireless Adapter ???

This wireless adapter’s model is ath10k :smile:

Through this wireless adapter is very powerful & good for Windows like OS but probably not very good for Hackers. Because, this wireless adapter has so many issues. Besides latest laptops are coming with this wireless adapter preinstalled

I am using a laptop which has this wireless adapter. But for pentesing works I use ‘TP-LINK TL-WN722N v1’ which is a awesome wireless adapter with chipset AR9271

No more talk comming to the point :smile:

QCA9377’s main problem is the ‘Monitor Mode’ not working. Which is very much needed for pentesing works. There are many repo in GitHub & they are claiming to fix this problem. But I am not getting the problem fixed

Running the ‘dmesg’ command as a root user I have came to know that the missing firmware and driver related issues are given below

[ 14.806015] ath10k_pci 0000:03:00.0: firmware: failed to load ath10k/pre-cal-pci-0000:03:00.0.bin (-2)
[ 14.806019] firmware_class: See [https://wiki.debian.org/Firmware ](https://wiki.debian.org/Firmware)for information about missing firmware
[ 14.806040] ath10k_pci 0000:03:00.0: firmware: failed to load ath10k/cal-pci-0000:03:00.0.bin (-2)
[ 14.806065] ath10k_pci 0000:03:00.0: firmware: failed to load ath10k/QCA9377/hw1.0/firmware-6.bin (-2)
[ 15.072773] ath10k_pci 0000:03:00.0: firmware: direct-loading firmware ath10k/QCA9377/hw1.0/firmware-5.bin
[ 15.072786] ath10k_pci 0000:03:00.0: qca9377 hw1.0 target 0x05020000 chip_id 0x003820ff sub 1a3b:2231
[ 15.072789] ath10k_pci 0000:03:00.0: kconfig debug 0 debugfs 0 tracing 0 dfs 0 testmode 0
[ 15.073318] ath10k_pci 0000:03:00.0: firmware ver WLAN.TF.1.0-00002-QCATFSWPZ-5 api 5 features ignore-otp crc32 c3e0d04f
[ 15.276928] ath10k_pci 0000:03:00.0: firmware: direct-loading firmware ath10k/QCA9377/hw1.0/board-2.bin
[ 15.277152] ath10k_pci 0000:03:00.0: board_file api 2 bmi_id N/A crc32 8aedfa4a

Important Links: →

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=903437

https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/tree/ath10k/QCA9377/hw1.0

Distros like ‘WifiSlax’ has this wireless driver preinstalled & also contains ‘aimon-ng-old’ package for older driver support

But nothing worked for me. Besides when the Linux driver for QCA9377 is installed it shows ‘unknown event id’ errors

Please help me fix the problem if anyone fixed it :smile:

I have had issues with Atheros drivers in the past. From memory I think it might have been a kernel issue. Try updating the kernel and see if that fixes it.

No @TR99, the problem is very complicated. If that was a kernel issue then it shoukd have been fixed in latest 4.19/4.20 kernel

I have also used latest backport releases but nothing works. Also tried reversing but nothing works

Really the problem is a piece of shit :angry:

Maybe time to get another card. Something a little more user friendly.

I am already using a external wireless card which is more than awesome & it is the
‘TP-LINK TL-WN722N v1’

No, We Hackers are not like that
If a problem occurs we have to research to find the bug to fix the problem
That’s why Hackers are awesome

Cheers :smile:

Hey @pry0cc, @Cry0l1t3
Do you have any idea why this problem is occuring ???
Internal wireless adapter is very useful when there an attack needs two wireless card simultaneously

Just buy an Alfa Card.

Thank You @pry0cc Bro
I have this card which is very good. Besides I’m using TPLINK TL-WN722N v1 which is also a good adapter :smile:

Some problems are not worth the effort if you have bigger things to do. You could also get a replacement internal card. Usually easy to replace.

I have the same adapter. Other than being cheap, I really like TP-Link stuff.

@TR99, I would love to use only one external wireless adapter if the internal works perfectly :smile:

1 Like

I always carry two just so for special occasions. :joy:

This topic was automatically closed after 30 days. New replies are no longer allowed.