Remote Exploit. Shellcode without Sockets

shellcode
exploit
remoteshell

(Command-Line Ninja) #21

Man this article has a lot of viwss


#22

I wonder why, pry0cc :wink:


#23

Hi there! I’m new around here. I tried to follow this tutorial and it sort of worked out. It generates the shell but immediately after it finishes the child process (which is /bin/dash), why is that?

Thanks!


(pico) #24

Hi @p3rla,

Thanks for following the tutorial and for your feedback.I have seen that happening some time ago. As far as I remember it happens when you mix up 32bits and 64bits code. In those cases you need to do some extra work to invoke the system call. I’m not sure if I took notes from those tests but I’ll let you know if I found them.

I have running it with dash (my /bin/sh is a link to /bin/dash) and it was working fine.

To know more about how the mixing on 32bits and 64bits code works I recommend the two following brilliant articles. Specially part 2 explains how this mix is managed by Linux.

Hope this helps


#25

Thank you very much for you response! You are actually right, I’m mixing 32bit and 64bit.
I’ll take a look at these articles :slight_smile:


(system) #26

This topic was automatically closed after 30 days. New replies are no longer allowed.