Anyone used the AWUS036ACH with Kali Linux?

wifi

(Saaid Minh) #1

I was doing some research into the current adapters on the market that are Kali friendly, and I read that this year Kali started supporting drivers for RTL8812AU wireless chipset. That means it supports the AWUS036ACH, which is a beast.

A few posts I’ve read indicate this does work. I wanted to ask, has anyone tried using Kali with this? Or has anyone found other new adapters that use this chipset?

Post on setting it up:
https://www.linkedin.com/pulse/kali-linux-rtl8812au-wireless-card-injection-steven-perry

From Alfa:

The AWUS036ACH manufacturer page
https://www.alfa.com.tw/products_show.php?pc=137&ps=225


(Austin) #2

I haven’t used use this chipset in Kali yet but I am currently use it for a research setup on Ubuntu 16.04 in the lab I work at. We upgraded to this from some TP-Link WN722N v1’s and they work amazingly in monitor and ad-hoc modes. I have been pushing a lot of data through them and haven’t any majors issues yet.


#3

It really doesn’t matter if it’s Kali, Ubuntu, Arch, or Fedora. As long as you have the correct module in /lib/modules/version-name/ for the kernel, it should all be okay. I clearly remember it being supported since the 4.0 release, and the relevant kernel module is 8812au. The driver isn’t in mainline, afaik.


(B2Crypt) #4

Maybe not related to the orignal post, but I’ve just had problems with awus051nh in monitor and proxmode in Kali.
I hope someone maybe got a tip or two.


#5

Myself and three other testers here have this card and have all been having issues with drivers.
The card will work for an intermittent amount of time, then drop. Also had issues setting monitor mode with airmon, instead having to use iwconfig.
Tried multiple drivers, the one advised by Alfa, the kali driver and other drivers around the net to no avail.
Some of us are going back to older models, it’s a shame. Hopefully they release / fix the drivers soon.


(Saaid Minh) #6

Did you find any workarounds that were effective?


(Saaid Minh) #7

Can you describe the problems you’ve had?


(B2Crypt) #8

Of course. The issues I have is that the 5ghz is very unstable, I find those networks a few times if I’m lucky. I cannot set the antenna in prox or monitormode, if I try airmon-ng, then nothing will show up or the antenna just disappear from the OS and I need to reboot… All of this is on linux. For me it both sounds like a issue with the drivers or it dosn’t support monitoring/prox at all.


(Saaid Minh) #9

Thank you. I’ve been monitoring the sales and a lot of our users bought this, so I’m going to keep tabs on any issues they have. Do you mind if I quote you so prospective buyers are aware of the specific issue?


(B2Crypt) #10

Go ahead, I don’t mind. :slight_smile:


(system) #11

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.


Kali and WIFI AWUS036AC Adapter