Hacking an old freebsd

Hi, I’m new to this site, and this is my first question.
I started hacking recently, and I started roaming around in some servers. One of those is an old freebsd server ( FreeBSD 9.0). I got in and escalated my privileges to root, and now I’m stuck.
Thing is, the default pkg manager is not working, for how outdated the os version is (2013). Updating it isn’t an option because i might break some dependencies and the sysadmin might notice my activities.
So I’m stuck with a basic install, without nmap or anything else.
Then I tried transferring some packages to it, and compiling them to no avail, as the os hasn’t the required dependencies (e.g. compiling nmap, directly from the github source).
I thought of pivoting with a meterpreter shell, but the system has problems running elf files even using ‘‘brandelf -t linux …’’ . I tried pivoting again with an ssh dynamic port forwarding (carefully setting up freebsd to accept it) but the socks4 proxy doesn’t work, for some obscure reason.
Then I used sshuttle, but again the os is missing some dipendencies.

And now I find myself unable to pivot to the other intranet machines.
Someone knows how to help me in pivoting from this server?

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.