Linux login loop problem...(Solved)


#1

I am stuck at the login of Ubuntu and cannot login, Iv’e tried multiple solutions to this online for about 2 hours and failed.
Here is the output of the .xsession-errors file:
openConnection: connect: No such file or directory
cannot connect to brltty at :0
Script for ibus started at run_im.
Script for auto started at run_im.
Script for default started at run_im.
init: logrotate main process(15081) killed by TERM signal.
init: Disconnected from the D-Bus bus


(Command-Line Ninja) #2

OK bro. When you say “you tried to login and it failed” what do you mean? Do you get to the login page at all? Does it crash after you type your details and log in? It might be an issue with either your DE or your DM.


#3

Yeah that’s what I said and to your third question, I login and the screen turns black and loops back to the login page. I am using lightdm. I tried reinstalling it, I even tried using gdm and it didn’t work. So then I thought maybe its the .Xauthority file at $HOME but nope, So i deleted other files that read ICEXauthority or .Xauthority.backup but it’s still not letting me log in… I’ve had this problem before but I fixed it by removing the .Xauthority file and logging in again; however, this time around that solution does not work.Before this happened I updated wine to 1.7 but I doubt that had to do with this problem, but who knows. :0


(Command-Line Ninja) #4

Try opening up a tty window with CTRL-ALT-F2, login, and do startx. What happens?


#5

It just crashed. 0.0


(Command-Line Ninja) #6

Do you get any errors with it at all?


#7

Screen turned dark and there was a blinking _ at the top-left of the screen.


#8

I waited but it just returned to the login screen
and failed login again.


(oaktree) #9

Did you install a new DE or something before experiencing this problem?

I had this issue after installing KDE.


(Command-Line Ninja) #10

Can you think of anything you’ve done/changed before, that has made this occur? Perhaps even before a reboot?


#11

Before the problem occurred I was updating wine to 1.7 and then I rebooted after the update and then it just didn’t let me log in.


(oaktree) #12

Okay. Have you tried Googling around??


#13

Oh yep… And im still looking.


#14

I fixed it! :slight_smile: The problem was my nvidia drivers. I deleted them and reinstalled them after. I did run into one problem after which was the resolution being stuck on 640x480 so I deleted the xconf file and rebooted; however, I don’t actually know what the conf file is or does but it fixed the resolution. The only thing I can think of is it being related to the fixed resolution related to the nvidia drivers. But I fixed it so yay!


(Command-Line Ninja) #15

Glad you solved it! :slight_smile: