OpenSSL problem


(0x5) #1

Hello guys ! today i just installed kali and i tried also to install slowhttptest alright everything is fine for now but when i try to ./configure i got OpenSSL -devel is missing. any ideas how can i install it/get it :slight_smile:

Thanks in advance ! Best Regards


(Security Architect & Founder) #2

It seems you don’t have the openssl development library.

Try sudo apt-get update && sudo apt get install libssl-dev

You may then need to try installing Linux headers sudo apt-get install linux-headers-$(uname -r)


(0x5) #3

Thanks a lot i will try it :slight_smile: but later since i’m little busy now ! also i’m really happy to enjoy 0x00sec !

-Cheers


(Security Architect & Founder) #4

Welcome to the community! I look forward to reading your comments and posts!


(0x5) #5

Thanks :slight_smile: and by the way when i tried to install the headers i got Couldn’t find any package by glob and regex "linus-headers-4.3.0-kali1-686-pae also when i try to install the libssl-dev i got Unable to locate package libssl-dev !

watched many tutorials still nothing ! also before that i learned some basic things before to start with kali and to be honest i’m really motivated to learn it :slight_smile:


(Security Architect & Founder) #6

Double check you’ve spelt linux-headers right.

Try sudo apt-get install openssl-dev


(0x5) #7

I do that sir! Reading package lists …Done
Building dependency tree
Reading state information … Done
E: Unable to locate package openssl-dev


(Security Architect & Founder) #8

Ugh thats strange. Join us at our IRC channel.

Either ##0x00sec or try this link


#9

Greetings.

32 or 64 bit OS?
Will try and get you fixed over here to help future masses.


(0x5) #10

32 Sir ! tried many other things but still nothing ( i got error while trying to install 64 thats why i changed to 32)

-Cheers


#11

Have you tried:

  • Synaptic Package Manager?

-OR-

  • sudo apt-get install libssl-dev?

For 64 bit OS and 32 bit packages in the future this may help.:

  • dpkg --add-architecture i386
    apt-get update
    apt-get install libssl-dev:i386

You can always do a build-dep but is no undoing it in one command afterwards


(0x5) #12

i will try the second thing ! first i got error like there’s a packages that are missing thats why i cannot install libssl-dev
edit : same buddy : Unable to locate package libssl-dev:i386


#13

Anything up there work?


(0x5) #14

if you talk about libssl no but other things there working


#15

O k . C o o l ? (1234 st00pid post 15 char minimums and SEO)


(Cal0X) #16

@spylegion Try updating your repository source list. Solved many problems regarding updates for me.