Problem with airmon-ng


(0x5) #1

Hello guys :slight_smile: so recently i tried something with airmon-ng but whenever i run it i got "Cannot access /sys/class/ieee80211/โ€™ " : No such file or directory

Things i tried

  • apt-get update && apt-get upgrade && apt-get dist-upgrade -y

  • apt-get install linux-headers-uname -r

  • apt-get install synaptic -y

  • Reboot

The result from iwconfig is

  • lo no wireless extensions.

  • eth0 no wireless extensions.

Any advices ? :slight_smile:


#2

Well look whoโ€™s back!

First things first: are you running from outside a VM and is your wifi chipset supported by aircrack?

-Phoenix750


#3

Are you sure the drivers are installed correctly?

I did a 2ms google research and I found this thread http://unix.stackexchange.com/questions/306836/airmon-ng-ls-cannot-access-sys-class-ieee80211-no-such-file-or-directory. It might help.


#4

Spoderman pls.

Well he is right too, but be sure to check if your wifi chip is compatible too @spylegion.

-Phoenix750


(Cal0X) #5

Are you using an external adapter or internal one? Most of the time internal adapter (the one which comes along built-in) donโ€™t support airmon.

Cal0X


(0x5) #6

Seems i have to get external adapter, because kali does not support my current one, and yes Phoenix iโ€™m using VM :slight_smile: Anyway thanks a lot for everyone who respond to this thread <3


#7

VM, also known as Virtual Machine, doesnโ€™t have access to your NIC directly.
You will need an external WLAN adapter and support for USB in the VM.


#8