[Solved!] Grub won't allow me to access anything! (Not even through USB!)


(CTRLtheALTofDELETE) #1

I decided to replace Kali Linux on my laptop with Lubuntu. I already had Kali Linux set up to dual-boot with Windows 10, using Grub2 bootloader.

When I ran the fancy Lubuntu graphical installer, all went fine. I told it to install itself in Kali’s partition. Unfortunately, when it did that, it replaced some of Grub’s files. Now, when I try to start my computer, Grub comes whining at me with error: file not found. and grub rescue>

-I checked in boot/grub/i386-pc/ and I do have a normal.mod file and a linux.mod file. When I set prefix to boot/grub/ or boot/grub/i386-pc/ and set root- insmod normal returns error: symbol not found: 'grub_divmod64'. and insmod linux returns error: symbol not found: 'grub_realidt'.

From when I push the power button:

  • Lenovo screen pops up for a second, with cursor on top left
  • Boots straight into grub rescue> ignoring the flashdrive I have plugged in.

I tried all the online answers I could find. When trying insmod normal or linux, it couldn’t find the files. (after mapping it to the Grub folder) I also was not able to run boot-repair-disk from a flashdrive- it went straight to Grub. By BIOS/UEFI settings should already be set to boot from a CD/USB first, (It had to be to run the Lubuntu installer). I used Rufus to install the boot-repair-disk iso file on the flashdrive, with a FAT32 system and GPT partition.

I’m not sure what to do now. Can I configure Grub to launch into Windows instead, and fix it from there? Or is there a way to launch into boot-repair-disk?

Thankyou for reading and helping! (There was no one on in the IRC unfortunately when this happened)
Sorry if this doesn’t make complete sense or if I missed anything, it’s past midnight now and I’ve been working on this for 2 hours. I’ll check in the morning and fix up what I can. :slight_smile:
-CtrlAltDelete

Laptop Info
- Ideapad S415 Touch
- AMD A6 Quad-Core processor
- Grub2
- Windows 10
- Kali Linux ----> Lubuntu
- Single Harddrive

[EDITED- Fixed formatting issues]


(CTRLtheALTofDELETE) #2

Summary

Thank you to Hattori and OakTree for helping me find the solution!
I’m writing out this summary to help anyone else that runs into this problem later.

The Problem

On my Lenovo Ideapad S415 touch, I had Kali Linux and Windows 10 set up to dual boot with Grub. I decided that I was going to remove my Kali Linux OS and install Lubuntu OS. I downloaded the Lubuntu .iso file, and wrote it to my 4GB SanDisk flash-drive using Rufus. Then I plugged it into my laptop and restarted. After the restart, it launched into the USB, and I selected “Install Lubuntu”. Then I ran the installer. For the partitions, I told it to install Lubuntu on the Kali Linux partition. (Which I had not deleted). This messed up some of Grub’s files, and after the install was complete, and I restarted my computer, I found myself at the grub rescue> prompt and unable to access either of my operating systems. I followed some online guides, but both insmod normal and insmod linux returned errors. (error: symbol not found: 'grub_divmod64'. and error: symbol not found: 'grub_realidt'. respectively). After this, I tried the boot-repair-disk program from a flash-drive, but it was ignored and my computer booted straight back into grub repair>. After this, I did some more investigating, but I couldn’t find a way to make the Grub files work. Then Hattori got back to me on the IRC and suggested re-trying the install, but properly removing the partition first. He also found an Ubuntu question that could help. I’m at this point now as I’m writing, so I will attempt this fix, and finish this for anyone else who needs the solution. :slight_smile:
After putting the Lubuntu .iso back onto the flash-drive, I tried running it, but it is apparently ignored and my computer goes straight to grub rescue>. I even tried a cold restart, (Disconnect battery & charger, hold power button down 15+ seconds) and still didn’t work. I have not found a way to access my BIOS without first launching into Windows 10 (Which Grub won’t allow).

Shortened: The problem was caused by me trying to install Lubuntu over Kali without first deleting or formatting the Kali partition.
I launch straight into grub rescue>, I can not insmod normal or insmod linux. I can not launch anything from a USB.

After going through every possible solution with some friends (IRC :slight_smile:) I determined that the only solution would be to disconnect my HDD, boot live Lubuntu, reconnect my HDD, and format the Lubuntu partition on the HDD to be free space. Then I Could retry the Lubuntu install.

Okay, tried a bunch of things, they didn’t work. However, I did manage to launch into Lubuntu (Or any OS I want) on my HD! I removed my HD, and then launch Super Grub from a USB. Then I re-inserted the hard-drive. Super grub was not able to find the HD then. But I went to the Grub CMD line and used the command exit and when my computer restarted, it launched into Super Grub again! And this time, it did detect my hard drive. I was able to launch into my OS. :slight_smile:
Now I am wondering (Asking some friends on IRC) if I still need to do a clean install of Lubuntu, or if I can fix the grub files now that I am on here.

##Solution
Note: I am not responsible if anything goes wrong while you try to perform this method. Be very careful with fragile hardware and be very careful of electric shock.
Note: This should work on most computers and operating systems, if you use Grub Boot Loader.

Situation: You have tried everything, everything!, and you can not bypass grub rescue> short of removing your hard drive.

The Fix: On another computer, get the Super Grub .iso file. Then, using Rufus or your favorite .iso burning program, burn the Super Grub .iso file to a flash-drive with at least 4GB of storage. WARNING: You will lose all files and information on that flash-drive! Save it to your computer if you want to keep it! When Super Grub is done writing, remove your flash drive from the computer.
Next, turn off your computer and preferably disconnect it from any power sources. Remove your hard drive from your broken computer. Be careful doing this! Handle hardware lightly and do not drop! Be wary of possible electric shock! After you remove your hard drive, put the case back on enough to protect the hardware. Especially on laptops, do not set the computer down on top of it’s hardware, make sure the case is back in the correct position to protect it! Now insert your flash-drive containing Super Grub into your computer. Start up the computer, and you should come to the Super Grub prompt. Now, being very careful of possible electric shock. replace your hard drive back into your computer. (While it is running). Then, in the Super Grub menu, press “c” on your keyboard, and then type “exit”. When the computer reboots, you should come back to the Super Grub program. Now, using your arrows keys and the enter key, select “Boot options”. Now, look through and find the correct boot option for the Operating System you are looking for.
To fix Grub: Launch into your Linux distribution, and run sudo update-grub in your terminal. This should repair Grub’s files. Now, you need to fix your Grub configuration. Grub config files are found in /etc/default/grub and /boot/grub/grub.cfg.
This is an excellent guide on configuring Grub. You could also refer to these excellent guides from HowToGeek and GNU.org

I was able to run sudo grub-mkconfig, sudo grub-install, and sudo update-grub. Then I restarted and it worked like new (Because it literally was new). This should work for most problems, as it completely re-installs grub on your hard drive.

Good luck! Please tell me if I leave anything out!